È preferibile installare CoPilot su smartphone Android che abbiano un sistema operativo uguale o superiore a 4.2. 


Allo stesso modo è raccomandabile utilizzare CoPilot su smartphone che abbiano a disposizione uno spazio di archiviazione sufficiente per opsitare i dati dell'applicazione e le mappe scaricabili. (Attenzione: è possibile salvare mappe sulla memoria esterna (SD card) del tuo smartphone solo a partire dalla versione Android 4.4.4 o superiore. Per le versioni antecedenti le mappe sono salvate sulla memoria interna. 


Al fine di utilizzare CoPilot è necessario avere un ricevitore GPS interno o esterno.

Infine è sempre preferibile utilizzare CoPilot su dispositivi che siano aggiornati all'ultima versione di Sistema Operativo.